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PetroPlot Tutorial

(The development of the PetroPlot tutorial package is inspired by Professor Dennis Geist, professor Bill 
White,  and Professor David Christie)

●     PetroPlot files (Explains PetroPlot files and their functionality)

●     PetroPlot startup (How to install PetroPlot and how to get the menu bar)

●     The "Muiti-XY Plots" function

●     The "ChangeXY" function

●     The "Add Data Label (XY Chart)" function

●     The "Spider Diagram" function

●     The "Label Log Scale" function
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●     The "Clear Values" function

●     The "Correl Matrix" function

●     The "Multiple Average" function

●     The "Delete Sample" function

●     The "Grouping" function

●     The "Compile Rows" function

●     use "Cubic Spline Interpolation functions"

●     The imported "Bovey Data Labeler" tools
❍     The "Add Chart Labels" function

❍     The "Move Chart Labels" function

❍     The "Manual Labeler" function

●     PetroPlot known problems
❍     Install PetroPlot.xla on Macintosh

❍     Use numbers as legend for spidergrams

❍     Empty cells when using "Multi-XY Plots"

❍     Chart type is not XY Scatter

❍     A chart contains data from multiple files or sheets

●     PetroPlot conventions

●     Using Visual Basic Editor in Excel



PetroPlot FAQ

       Excel questions

●     Q: How to move a chart from embeded object inside a worksheet into a seperate chart sheet?
A: Click Excel menu: Chart --> Location 

●     Q: Most people, including myself, would like multiple panels in a single figure when preparing 
publications. Can you make XY plots with fixed PLOT area (vs. fixed CHART area)?
A: We have tried a variety of ways, but couldn't get a fixed Plot area. We'll continue to investigate 
the possibility. If you know any infomation about it, please contact us. 

●     Q: When making log scale XY plots, the default minimum and maximum values on axes are fixed 
to 10’s and 10th – i.e., 0.001, 0.01, 0.1, 1, 10, 100, 1000 etc. ? Is it possible that maximum and 
minimum on an axis can be of any values, say, 0.2, 0.6, 20, 40, 200 etc?
A: We couldn't get flexible scales on a real log scale axis.
     However, we manage to label a linear-axis using log scale. Please try our "Label Log Scale" 
function 

       PetroPlot Specifics

●     Q: I made an XY chart, why did PetroPlot tell me it's not an XY Scatter?
A: Mostly likely you added some lines to connect the points. Read more... 

●     Q: PetroPlot used to have "Remove Data Label" function, why is that gone? How do I remove 
labels?
A: To remove labels for a series in a chart, simply select the labels, and hit the "Delete" button on 
you keyboard.
     Since it's an easy operation, we deleted the "Remove Data Label" function. 

●     Q: I have always found it useful to leave the first 2 lines of each spreadsheet for titles and 
information about the contents. I encourage the authors to consider a modification to this effect. 
A: Though the examples we provided put header on the first line, and data start from the second 
line, PetroPlot doesn't reserve the second line for data. You can certainly put more info lines on 
the top of a worksheet. PetroPlot does reserve the first line to be column header

Q: Even more useful would be giving the user the option of specifying which line contains the 
column headings.
A: We consider this as a good suggestion, and will implement it in the next generation of 

mailto:ysu@ldeo.columbia.edu


PetroPlot software. 

●     Q: The biggest change that I would like to see concerns the “Change XY” routine. At present, this 
routine works for only one plot at a time. It would be really useful to combine the rapid multi-plot 
functionality of “Multi XY Plots” with the ability to use a template to specify the symbols used.
A: Excellent idea. We'll consider it for PetroPlot2.0. 

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot tutorial homepage 



PetroPlot Tutorial

Directories and files
The folder Excelfile contains four files: PetroPlot.xla, PetroPlotSpider.xls, PetroPlotExampleData.xls, spline 
example.xls. 

 

 PetroPlot.xla
As the core Excel add-in library file, "PetroPlot.xla" is required for all PetroPlot functions. Similar to other 
Excel add-in libraries, this file runs in the background in Excel. The source codes can be viewed in Visual 
Basic Editor. (How?)

 PetroPlotSpider.xls (Note: the name of this file should not be modified.)
This file contains normalization standard values for spider diagrams. Required for the PetroPlot Spider 
Diagram function.

It is provided with three worksheets: REE, AllTrace and MyValues.
The REE and AllTrace worksheets contain chondrite, primitive mantle and average MORB values from Sun & 
McDonough (1989) and McDonough & Sun (1995).



The MyValues worksheet is a demo showing how a customized worksheet could be added to the 
PetroPlotSpider.xls file.



All worksheets in PetroPlotSpider.xls obey 3 rules :
(1) Each row represents a normalization standard; each column contains values for one element.
(2) Standard names must be in Column A, and element names must be in Row 1.
(3) “-1” is required as termination value in both Column A and Row 1. Extra information beyond the “-1” signs 
will not be used for spider diagram plotting.

Users may add an arbitrary number of worksheets. Inside each worksheet (including the provided AllTrace and 
REE), arbitrary numbers of standards or elements can also be added. The order of elements can be changed, 
and the data values can be modified. In another words, the spider diagram normalization values can be fully 
customized.

 PetroPlotExampleData.xls
An Excel file with petrology data for the demonstration purpose ONLY.
Data source is Niu and Batiza (1997). 



The format of an ordinary file should follow the format of this example file.
For instance, in a data sheet, each row represents a sample/analysis; each column represents a category 
(location, element, element ratio, etc) and the first row is always reserved for headers (i.e. element names etc). 

However, unlike the PetroPlotSpider.xls, it is not required to put sample names in Column A.
Data can begin on any row below row 1. 

 spline example.xls
An Excel file for the demonstration of the spline functions.



Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Directories and files 



PetroPlot Tutorial

Installation
System Requirements
Any system that runs Microsoft Excel 97 (Office 97) or higher. 

Open PetroPlot library: 
There are two ways to open the PetroPlot.xla library:
1) Manually open the file;
2) Install it once, then it will automatically open each time Excel starts. 

1) Manually open
You can directly open the "PetroPlot.xla" in Excel, and remember to "Enable Macros".

2) Install "Add-ins"
To avoid manually opening this file each time you wants to use it, you can install it through "Add-ins"

(Known problem for Mac: On some old MAC OS, the installation of PetroPlot Add-In may cause Excel to 
take a long time to start.  If that happens, is it suggested you manually open the PetroPlot.xla instead of 
installing the Add-In.) 

Step 1. In Microsoft Excel, open "Tools" menu bar, click "Add-Ins" button 



Step 2. click the “Browse” button to locate the PetroPlot.xla file.

Select the PetroPlot.xla



Step 3. Find "Petrology Plot Tools" (or “PetroPlot”) and select it. Click the "OK" button.



Active PetroPlot library: 
Now under "Tools" menu bar, there should be a button called "Active PetroPlot"
Click “Active PetroPlot" to activate “PetroPlot” Menu bar.

Here is an example of PetroPlot menus in sheet mode



Here is an example of PetroPlot menus in chart mode



Close and uninstall PetroPlot
You can hide the “PetroPlot” menu by clicking the “Close PetroPlot” button.



Notice that the PetroPlot library is still open. 

If you want to uninstall it, go to "Tools" --> "Add-Ins...", then deselect the "Petrology Plot Tools" option.



Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Installation 



PetroPlot Tutorial

Multi-XY function
Purpose: 
The PetroPlot multi-plot function makes a large number of XY plots at one time. 
Each plot allows multiple groups of samples to be plotted using discrete symbols. 

 Here is an example output of this function. 



Start: 
Open "PetroPlotExampleData.xls" in Excel. 
Activate the "data" sheet.

Notice: the first row of data sheet is reserved for headers (i.e. element names etc). This is mandatory to use PetroPlot.

In this example, Column A is reserved for series name, and column B is reserved for series number.
This setup is optional. PetroPlot does not require the column positions. However, we suggest that you use the first two columns for series 
name & number.

Step 1: 
Select the data range on "data" sheet. 



You don't need to select the series name & series number columns if they are the first two columns on the sheet

Step 2: 
Click the "Multi-XY plots" button 



The Select Data window appears. 

You can modify the data range by clicking the right side of the input box.



Set the Header position and series info position, then click the "Next" button.

Step 3: 
Choose axes. 



You can select ONLY ONE X-axis. 

Hold the Ctrl key to select multiple Y-axes. 

All the right side inputs are optional. 



Now click the "Next" button. 

Done! You get the plots as in the result diagram.

Known problems:
Empty cell problem.
If there exist empty cells in the selected data range, the PetroPlot program might hang up. Details... 

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Multi-XY function 



PetroPlot Tutorial

ChangeXY function
Purpose: 
This function changes axes for all series in a single XY plot, while preserving the chart format.
It is useful for generating multiple high-quality plots with complex formatting, especially when there are a large number of series. 

For example, the formatting of the XY charts follows Excel’s default settings, which might be unsatisfactory. 
In the following, series 1 uses blue diamonds, series 2 uses pink squares, and series 3 uses yellow triangles, etc. You may want to change the colors or the shapes

Start: 
Format the diagram as you want. This is your template. 



Step 1: 
We suggest that you copy the template to another location inside this workbook. 
(The ChangeXY function does not work if a chart contains data from other workbooks.)



Step 2: 
Select the diagram, Click the PetroPlot --> ChangeXY button. 



Step 3: 
Change the X or (and) Y axes. 
This example changes X axis.

This example changes Y axis.



Step 4: 
Click the "Next" button. 



Step 5: 
The scale of new plot needs to be manually adjusted. 



Result: 



Known problems:
1. Not XY Scatter.
If there exist lines connecting scatter points, the PetroPlot program won't continue. Details...

2. Data from other sheets or other files.
PetroPlot only changes series with data from the current workbook. All series need to come from the SAME SHEET. Details...

3. Label-log-scale charts.
PetroPlot does not changeXY on label-log-scale results. 

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: ChangeXY function 



PetroPlot Tutorial

Add Data Label (XY chart) function
Purpose: 
Excel automated data labels are limited to either X values or Y values. Customized labels such as sample 
names, locations, and references etc. are more valuable information on a plot. 

With PetroPlot, any kind of information can be labeled, and adding customized labels is as easy as to add 
Excel default labels. Labels added to a template chart will pass automatically if the chart is changed with 
the "ChangeXY" function.

We also imported a set of label tools from Rob Bovey (www.appspro.com).
"Bovey Chart Labeler" adds labels to a variety of chart types, including XY Scatter, Line, Column, Bar 
etc.
"Bovey Chart Labeler" moves labels of a whole series (Excel doesn't allow this type of movement by 
default).
Please visit Bovey Chart Labeler... 

Add label to a point: 
Select a point on XY scatter chart. 
(Excel tip: Clicking a point once gives you the selection of the whole series. Clicking the same point 
again gives you the point. NO double-clicking. )



Click PetroPlot --> Add Data Label (XY Chart)



Select label type & position. Here we will label the selected point with the sample name.

Result:



Remove data label for a point: 
Select the label.   Then hit the "Delete" button on your keyboard
(Excel tip: you may need to click the label twice to select the label. Warning: NO double-clicking. )



Add labels to a series: 
Select a series or a point on XY scatter chart. 



Click PetroPlot --> Add Data Label (XY Chart)



Select label type & position. In this case, we will label each point with the MgO content.

Result:



Remove labels for a series: 
Select the labels for a series   Then hit the "Delete" button on your keyboard



Add labels to all series in a chart: 
Select a point, a series, or the whole chart on XY scatter chart. 
Click PetroPlot --> Add Data Label (XY Chart)



Select label type & position. 



Known problems:
1. Not XY Scatter.
If there exist lines connecting scatter points, the PetroPlot program won't continue. Details...

2. Data from other sheets or other files.
All series need to come from the SAME SHEET of the current workbook. Details...

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Add Data Label (XY chart) function 



PetroPlot Tutorial

Spider Diagram function
Purpose: 
Spider diagrams are plots of normalized data where data for many elements are normalized to a reference 
such as primitive mantle. Such plots are commonly used to compare samples and to investigate trace 
element systematics in geochemistry. In order to make a spider diagram, the data have to be organized 
such that elements are in a specific order, and chemical values are divided by the standard values. 
PetroPlot “SpiderDiagram” function automates the entire process 

Start: 
Make sure the file PetroPlotSpider.xls is open. 
You can customize the standard values in the "PetroPlotSpider.xls" file.

Step 1: 
Select a set of rows on a data sheet. 
(Notice: You can select any column. PetroPlot only reads the row positions from your selection.)



Click PetroPlot --> Spider Diagram. 



Step 2: 
Select a column as legend for the spider diagram, then click "Next" 
(Warning: Don't use any number values as legend, e.g. if a sample is named as "32", rename it to a 
string.)



Step 3: 
Set up standard values (i.e. to what values data should be normalized). 



Select a worksheet: 
When you click a value in the upper left panel, the lower left panel will show standards in the selected 
worksheet 



Select a standard: 
When you click a standard in the lower left panel, the right panel will show values.
However, you don't need to select from the right panel. 
The right panel is for the purpose to check values and make sure those are what you want to use.



Click the "Next" button. Done! 

Results: 
PetroPlot adds a new sheet for selected samples, orders the elements based on the selected standard, 
calculates the normalization values, and makes line charts. 

Known problems:
Use numbers as legend.
If you use numbers as legends, the PetroPlot program will generate errors. Details...

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Spider Diagram function 



PetroPlot Tutorial

Label Log Scale function
Purpose: 
In Excel log scale plots, the default minimum and maximum values on axes are fixed to the integer powers of ten -- i.e., 0.001, 0.01, 
etc. It is desirable the maximum and minimum on an axis to be any value, e.g., 0.2, 0.6, etc.

The PetroPlot “Label Log Scale” function adds flexible log-scale labels to plot where log values have been calculated on a separate 
column on the worksheet. 

It works for not only XY Scatter chart, but also line chart or bar chart etc.

Here is an example of XY Scatter chart with Label Log Scale.

 

Here is an example of line chart with Label Log Scale.



 

Start: 
Calculate log10 values on worksheet. 

Make linear scale chart using the log10 values.



Step 1: 
Select the axis you want to label. 



Click PetroPlot --> Label Log Scale. 

Step 2: 
Type the log-scale labels. 
The selected axis will be rescaled based on your input.



Click "O.K." button. 

Notice the labels for Y axis are changed. 

Repeat for each axis you want to add log-scale-Label. 



Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Label Log Scale function 



PetroPlot Tutorial

Clear Values function
Purpose: 
An Excel calculation may return zeros or non-numeric values (e.g. "#VALUE!" or "#DIV/0!").

Aggregate functions such as average or standard deviation cannot be applied when the selection contains 
non-numeric cells. 

To manually delete these bad cells can be time consuming if the data volume is large. 

The PetroPlot function automates the cleaning process by making the meaningless cells empty.

Here is an example of a worksheet which contains non-numeric values & zeros.



 

Start: 



Select a range on the worksheet. 



Click PetroPlot --> Clear Values. 

Result: 



Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Clear Values function 



PetroPlot Tutorial

Correl Matrix function
Purpose: 
This function calculates a correlation matrix for a selected data area. The output is sent to a new worksheet. 

The result is similar to the correlation function in Excel Add-In “Data Analyses” tool package. The advantage of this PetroPlot function is that it outputs 
formulas instead of calculated values. If the source data are modified, the correlation matrix generated by PetroPlot will be automatically updated.

Start: 
Select a range on the worksheet. 



Click PetroPlot --> Correl Matrix. 



Result: (Notice that the formula instead of a value is entered in a cell.) 



Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Correl Matrix function 



PetroPlot Tutorial

Multiple Average function
Purpose: 
This function calculates multiple averages or other aggregates functions such as “STDEV”, “MIN”, “MAX” and “SUM” based on grouping 
classification that is planed in a separate column. Calculation formulas are exported to a new worksheet. The averages will be automatically 
updated once source data are modified. 

In the following example, averages will be calculated for each series based on the series name.

Start: 
Select a range on the worksheet. 

Click PetroPlot --> Multiple Average. 



Input the grouping column & formula:

Result: (Notice that the formula instead of a value is entered in a cell.) 



Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Multiple Average function 



PetroPlot Tutorial

Delete Sample function
Purpose: 
This function can delete non-consecutive rows based on customized criteria.

Start: 
Select a set of rows on a data sheet. 
(Note: You can select any column. PetroPlot only reads the row positions from your selection.)

Click PetroPlot --> Delete Sample. 



Input the deleting criteria:

Result:



Note:
The deleting condition could be as following. Only "between" needs two values.

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Delete Sample function 



PetroPlot Tutorial

Grouping function
Purpose: 
Samples are often grouped by a variety of criteria, such as locations, materials, chemical values, calculated indexes (e.g. Na8, La/Sm), 
analytical methods etc. 

The PetroPlot Grouping function reads grouping information from a grouping worksheet, and assigns grouping number/ID to individual 
samples in the data sheet

Start: Open PetroPlotExampleData.xls in Excel. 
The "groupinfo" worksheet should have 6 columns and 11 rows, with a "-1" at cell A12.

 

Step 1: Select rows you want to work on.
Note: you can highlight any column. 



 

Step 2: click the "PetroPlot" menubar. 



Then select the "Grouping" button.

Now you see the "Grouping" window. In this window, the program reads from the "data" sheet



 

Step 3: Set up the group info sheet. 
Note: you can make multiple group info sheets, and define different groups. 



Step 4: Set up the grouping columns. 
Note: Maximum number of grouping columns is 5. 

Highlight the column (image above), click the "Grouping Columns" button (image below)



Now Column "E" is added

 

Repeat to choose all Grouping columns. 



Step 5: Set up the output column. 
Could be any blank column.

Highlight the column (image above), click the "Output to" button (image below)



 

Step 6: Click the "Next>" button. 



Now you see the "Grouping Next" window. In the new window, the program reads from the "groupinfo" sheet.



 

Step 7: Tell the program which column in "groupinfo" sheet contains group names. 

Highlight the column (image above), click the "<<" button in the upper right corner (image below)



 

Step 8: Choose columns in "groupinfo" sheet to constrain your first grouping column in "data" sheet 
(in this example, the latitute column in "data" sheet"). 

Highlight the column, click the "<<" button next to the input box (image above) 
Repeat if the criteria is "between"(image below)

 

Step 9: Choose columns in "groupinfo" sheet to constrain your second grouping column in "data" sheet 
(in this example, the K2O/TiO2 column in "data" sheet"). 



Highlight the column, click the "<<" button next to the input box (image above) 
Repeat if the criteria is "between"(image below)

 

Step 10: Click the "Next>" button. 



Result:



 

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Grouping function 



PetroPlot Tutorial

Compile Rows function
Purpose: 
Data files downloaded from PETDB and GEOROC are sometimes listed as individual rows sorted by publication or analytical 
method. A single sample then has data that occupy more than one row. To manually combine all rows of one sample into a single row 
is very time-consuming, and can even take longer time than typing the data manually. 

The PetroPlot Compile Rows function automates this task by picking the first value of an element for one sample into a single row in a 
new sheet. If multiple values exist for that element, the result cell will be marked with an indicative color. 

Here we present an example

Start: Open PetroPlotExampleData.xls in Excel. 
Activate the "PETDBdownload" worksheet. 
There is no need to select any range. This PetroPlot function works on the whole sheet. 

http://petdb.ldeo.columbia.edu/
http://georoc.mpch-mainz.gwdg.de/


Click PetroPlot --> Compile Rows. 

Confirmation window, click "YES" 

Result: 



Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Compile Rows function 



PetroPlot Tutorial

Cubic Spline Interpolation functions
Purpose: 
These functions (Spline and Splint) implement the cubic spline algorithm for interpolating to any x-value given a series 
of (x,y) pairs. The interpolating function is made up of a sequence of cubic polynomial curves that meet at the given data 
points with continuous first and second derivatives. Significantly better than linear interpolation for relatively smooth 
data. See Press et al., Numerical Recipes 2nd Edition, pages113-116.

Start: 
Select a range of cells equal in length to your x and y arrays. 

Step 1: 



Choose Insert->Function. 

Choose ->User defined->Spline. 

Enter the range of x values, the range of y values, and the number of data pairs. 



To fill the whole selection: Type Command+Return(Mac) or Ctrl+Shift+Enter(PC)

This is a table of the numerical estimates of the first derivative of your function at each data point. You only have to do 
this once to generate the interpolating function, you can now use it multiple times for various values of x. 

Step 2: 
Now, to interpolate to any x value.
Select a range of cells equal in length to your x.



Choose Insert->Function->User defined->Splint. 



Enter the ranges of x values, of y values, of output from Spline, the number of data pairs, and the x value at which to 
evaluate the interpolating function. 



To fill the whole selection: Type Command+Return(Mac) or Ctrl+Shift+Enter(PC)

Result plotted. 

Problems: 
(1) The x-values must all be distinct, or the Spline routine will encounter a division by zero and fail.



(2) The data points must be sorted so that the x-values are either monotonically ascending or descending; otherwise the 
Splint function will fail to find the right pair of points that bracket the desired x-value.
(3) If the data are very noisy, the interpolating function can have wild swings to nonsensical values.

Last modified 05/30/2002, Paul D. Asimow and Yong Jun Su. 
This line marks the end of PetroPlot Tutorial: Cubic Spline Interpolation functions 
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PetroPlot Tutorial

Bovey Chart Labeler
Code Source: 
We imported a set of label tools written by Rob Bovey (www.appspro.com).
The version is the XY Chart Labeler 6.22.

The Bovey Chart Labeler menu 
Click PetroPlot --> Bovey Chart Labeler

*********************************************************************************************
*** Start of imported text from www.appspro.com

The XY Chart Labeler provides the following features:

●      Add XY Chart Labels - You can add labels to the points on your XY Chart data series from any selected 
range in the workbook. The label range can be oriented vertically or horizontally; named ranges are also 
supported. The labeler will pick up and apply the source range formatting characteristics to the data labels as 
well as live-link the data labels to the source range. Chages in the source range text will be immediately 
reflected in the corresponding data label.

●      Move XY Chart Labels - You can move the entire set of data labels or single specific labels in 1 point 
increments in any direction. Movement is dynamic, accomplished by the use of an arrow dialog, so you can 

http://www.appspro.com/utilities/Labeler.asp
http://www.appspro.com/utilities/Labeler.asp


see the results of your movements as you press the arrow keys.
●      Manual Labeler - There are times when you don't want to label an entire data series, but rather use data 

labels to highlight specific data points. The manual labeler allows you to do this. As with the normal Add 
Labels function, you can specify a range to use for the label. The manual labeler also allows you to type in 
label text directly.

And the best part of all is that even though this utility is called the XY Chart Labeler, it is capable of labeling any 
type of Excel chart series that will accept data labels. The specific labeling options that are available will vary 
depending on the chart type of the series one is attempting to label. 

Download the XY Chart Labeler 6.22 (for Excel 97/2000/2002)

*** End of imported text from www.appspro.com
*********************************************************************************************

Comparison of PetroPlot  "Add Data Label (XY Chart)"  with Bovey Chart Labeler: 

PetroPlot Labeler

●     Adds label for a selected point. You don't need to know the point order ahead of adding the label.

●     Adds label for all series in an XY Scatter chart at once.

Bovey Chart Labeler

●     Is capable of labeling any type of Excel chart series that will accept data labels.

●     Can move all labels for a series.

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot Tutorial: Bovey Chart Labeler 

http://www.appspro.com/downloads/XYChartLabeler.exe
http://www.appspro.com/utilities/Labeler.asp


PetroPlot Known Problems

Install PetroPlot.xla on Macintosh
Problem: 
On some old MAC OS, the installation of PetroPlot Add-In may cause Excel to take a long time to start. 

Solution: 
Do not install the Add-In. Manually open the PetroPlot.xla each time you need to use it.

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot known problems: Install PetroPlot.xla on Macintosh 



PetroPlot Known Problems

Use numbers as legend for spidergrams
Problem: 
If you use numbers as legends for spider diagram, the plots will have errors.

The following example uses "SiO2" values as legend.

The result looks like:



Solution: 
Avoid using numbers as legends for spider diagram.
Pay special attention to samples names which look like "23", "3/4", "3-4" etc.
Excel might treat "3/4" or "3-4" as "4-Mar", and count it as a number.

Last modified 05/30/2002, Yong Jun Su
This line marks the end of PetroPlot known problems: Use numbers as legend for spidergrams 



PetroPlot Known Problems

Empty cells when using "Multi-XY Plots"
Problem: 
If there exist empty cells in the selected data range, the PetroPlot program might hang up. 

In the following example, trace element data are not complete. 

Now we select a data range and run the PetroPlot "Multi-XY Plot" function



PetroPlot hangs up, gives only one series even we selected all data.



Solution: 
Create two columns with sequential data.



Run the PetroPlot "Multi-XY Plot" function



Format the TempX vs TempY chart



Copy the TempX vs TempY chart to another place, and run "Change XY" function

The result.
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PetroPlot Known Problems

Chart type is not XY Scatter
Problem: 
If you add lines to connect points on an XY chart, then the chart is not treated as XY Scatter any more.

The following example tries to run ChangeXY function.

Solution: 
You need to re-format the series to get rid of the lines.
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PetroPlot Known Problems

A chart contains data from multiple files 
or sheets

Problem: 
If an XY chart contains data from multiple files or sheets, PetroPlot ChangeXY or Add Data Label 
functions will not work for those series.

PetroPlot only changes series with data from the current workbook. All series need to come from the 
SAME SHEET.

Solution: 
Keep all data for an XY Chart in a single worksheet.
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PetroPlot Conventions
The following rules can help users to work more efficiently with PetroPlot functions.

1.  A data sheet should be organized with rows corresponding to sample/analysis and columns 
representing categories (location, element, element ratio, etc). The first row should contain only 
header information (i.e. element names etc). 

2.  All sheet-mode functions except “Compile Rows” work on selected areas in the data sheet. In 
general, whole sheet, whole column or whole row selections should be avoided. The program 
works most efficiently if only the cells with data to be worked on are selected.

3.  For “Multi XY Plots”, it is recommended that Series Names are stored in Column A, and Series 
Numbers are stored in Column B, as shown in the PetroPlotExampleData.xls file.

4.  To use PetroPlot “ChangeXY” function, data sources for all series in one chart must come from a 
single worksheet. Series with data from other files will NOT be updated to the new axes.

5.  “Spider Diagram” function requires that "PetroPlotSpider.xls" is open.

6.  Sample names should include a text string, and not be only numbers.

7.  For the “Grouping” function, at least one group info sheet is needed (e.g. the groupinfo sheet in 
PetroPlotExampleData.xls) . There are no naming restrictions for group info sheets. A “-1” sign 
should be put in Column A after the last grouping record. No “-1” is needed in the header row.

8.  To use the “Compile Rows” function, users should pre-sort the data sheet based on analytical 
quality. Make sure that better data appear first for a single sample.

If you think more or less rules should be listed here, please contact me. 

mailto:ysu@ldeo.columbia.edu
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PetroPlot Tutorial

Using Visual Basic Editor
Activate Visual Basic Editor: 

Click Tools --> Macro --> Visual Basic Editor

Locate the PetroPlot.xla in Project Explorer: 

PetroPlot forms: 



PetroPlot Modules: 



You can contact me for more information. 
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